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Introduction 

Image Menus can be used to display several links in a graphical way. Users can 

click on the images or the text to visit the linked page.  

There are several different types of image menus: 

• Small standard image menu 

• Large standard image menu 

• New style image menu (Moderators only) 

These all display differently and are set up differently.  
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Standard Image Menu 

A standard image menu displays several images, with text beneath each image: 

 

The Image Menu rearranges itself for smaller screen resolutions, e.g. mobile. 

 

Small standard image menus use images that are 120px wide. Large standard 

image menus use images that are 250px wide. Other than the size of the 

images, they behave in the same way.  
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Creating a Small Standard Image Menu 

1. First upload your images into the Media Library. They should be 120px wide. 

Images can be rectangular or square as long all the images have the same 

height, so that they will look uniform.  

2. Open or create your piece of content where the image menu is going to be 

placed – this is most likely to be a piece of general content. 

3. Using the editor create a bulleted list of items: 

a. Start first with just the text that you are going to have with each of 

your images: 

 

b. Next add the images that you are going to use with each item, to the 

left of the text. 

 

c. Next make each item in the list into a link. You will need to add a link 

to the image and add a link to the text separately. Don't attempt to 

add the link to both the image and text together, as there is a bug in 

the CMS which will wipe the text you added if you do this. For more 

information on creating links, see Information Sheet 4.2.  

https://www.aber.ac.uk/en/is/it-services/web/cms/info-sheets/
https://www.aber.ac.uk/en/is/it-services/web/cms/info-sheets/


    
 

Page 5 of 18 

Reviewed: April 2023 

d. Your bulleted list should now look like this: 

 

4. If you preview your page at this point you will see a normal bulleted list with 

images and text in it. We now need to convert this to the image menu. 

5. In the CMS editor you will see that when you click on an item in your list, 

some information appears in the bottom of the editing box. 

6. You can click on items in this area to select different parts. In order to make 

the list into an image menu, you need to select the whole list, by clicking on 

“ul” in this area. 

7. You will see that the whole list is now highlighted: 

 

8. Now you can apply the Image Menu style by using the Format menu at the 

top of the editing box. 

9. In the Format menu, choose 'Formats' and then in the sub-menu that 

appears, choose ‘Custom Formats’ and “image-menu-small”.   
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10. The image menu's appearance will change like this: 

 

11. Ensure that you preview your work before saving to make sure that the 

image menu has been correctly implemented. 

12. If you are happy with you image menu, save your work by clicking on the 

Save changes button and use the section preview from the site structure to 

check how your image menu looks within your page. 
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Creating a Large Standard Image Menu 

1. First upload your images into the Media Library. They should be 250px wide. 

Images can be rectangular or square as long all the images have the same 

height, so that they will look uniform.  

2. Open or create your piece of content where the image menu is going to be 

placed – this is most likely to be a piece of general content. 

3. Using the editor create a bulleted list of items: 

a. Start first with just the text that you are going to have with each of 

your images: 

 

b. Next add the images that you are going to use with each item, to 

the left of the text: 

 

c. Next make each item in the list into a link. You will need to add a 

link to the image and add a link to the text separately. Don't 

attempt to add the link to both the image and text together, as 

there is a bug in the CMS which will wipe the text you added if you 

https://www.aber.ac.uk/en/is/it-services/web/cms/info-sheets/


    
 

Page 8 of 18 

Reviewed: April 2023 

do this. For more information on creating links, see Information 

Sheet 4.2.  

d. Your bulleted list should now look like this: 

 

4. If you preview your page at this point you will see a normal bulleted list with 

images and text in it. We now need to convert this to the image menu. 

5. In the CMS editor you will see that when you click on an item in your list, 

some information appears in the bottom of the editing box 

6. You can click on items in this area to select different parts. In order to make 

the list into an image menu, you need to select the whole list, by clicking on 

“ul” in this area. 

7. You will see that the whole list is now highlighted: 

 

13. Now you can apply the Image Menu style by using the Format menu at the 

top of the editing box. 

https://www.aber.ac.uk/en/is/it-services/web/cms/info-sheets/
https://www.aber.ac.uk/en/is/it-services/web/cms/info-sheets/


    
 

Page 9 of 18 

Reviewed: April 2023 

14. In the Format menu, choose 'Formats' and then in the sub-menu that 

appears, choose ‘Custom Formats’ and “image-menu-large”.   

 

15. The image menu's appearance will change like this: 

 

16. Ensure that you preview your work before saving to make sure that the 

image menu has been correctly implemented. 

17. If you are happy with you image menu, save your work by clicking on the 

Save changes button and use the section preview from the site structure to 

check how your image menu looks within your page. 
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New Style Image Menu (Moderators only) 

A new style image menu displays several portrait images, with text over the 

bottom right corner of each image: 

 

The Image Menu rearranges itself for mobile screen resolutions or if a user has 

their browser in a smaller window. 
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Note: New style image menus can only be created by Moderators because a 

new section must be created, but if you already have one in your site, it can be 

edited by both Contributors and Moderators. 

Images used for a new style image menu must be 336px wide and 388px high. 

The images should be less that 50kb in file size otherwise the CMS will not 

accept them. 
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Creating a New Style Image Menu 

Add content where you want the image menu to appear 

1. Open the section in the CMS where you want the image menu to appear. 

2. Click on the Content tab. 

3. Click Create content and choose 'Display Image Menu' 

4. The 'Display Image Menu' template is displayed: 

 

5. Give the piece of content a name. 

6. Click Save changes to save the content. 

7. If required, you may need to order the content in your section so that your 

image menu appears in the correct point in the page. See Information Sheet 

8 for further information on reordering content. 

  

https://www.aber.ac.uk/en/is/it-services/web/cms/info-sheets/
https://www.aber.ac.uk/en/is/it-services/web/cms/info-sheets/


    
 

Page 13 of 18 

Reviewed: April 2023 

Add the image menu items 

8. Return to the Site Structure and find the section where you want the image 

menu to appear. 

9. Click on the Actions button to the right of the section you have chosen, and 

the Actions menu will appear. Choose 'Create Section'.  

 

10. The General Section Details page will appear: 

 

11. Type image-menu as the name of the section. It is important to use the 

correct wording, or the image menu will not work. 
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12. Un-tick the “Show in navigation” tick box so that this section will not show 

up in the left menu. 

13. Click Save changes at the bottom of the screen 

14. You will be returned to the Site Structure 

15. Click on the plus sign to expand your section so you can see your new 

image-menu section 

16. Click on the image-menu section 

17. Click on the Content tab  

18. Click Create content and choose the appropriate type of content for each 

item you want in your image menu: 'Image Menu Item (internal)', 'Image 

Menu Item (external)' or ‘Image Menu + Text Item (internal)’.  

 

Notes: You should use 'Image Menu Item (internal)' if your link is going to go 

to another section within the CMS.  

If you need to link outside of the CMS (e.g. a link to the Student Record), then 

you should use the 'Image Menu Item (external)'. 

‘Image Menu + Text Item (internal)’ can be used if you want to include 

additional text (e.g. a brief description) along with the title of the section you 

are linking to. The text is limited to 100 characters. 
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19. 'Image Menu Item (internal)' 

a. The template will be displayed: 

 

b. Give the item a name. You may wish to use the same text as will 

appear to the user, so you can see which item is which in the content 

list. 

c. Click the 'Add section link' button to choose the section you wish to 

link to. 

d. When you have chosen the section, it will be displayed beneath the 

Add section link button. 

e. You can use the name of the section you are linking to as the link text 

by leaving the 'Use default link text' tick box ticked. If you wish to use 

different wording, untick the box and type your chosen text in the 

'Enter custom link text' box which appears. 

f. Click in the box next to Image to choose your image file. Alternatively 

drag the file from your computer onto the box. Make sure the image is 

the right size (336x388px) and that it is no bigger than 50kb in file 

size. When you have chosen your image, it will be displayed in the 

box. 

g. Click Save changes to finish. 
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20. 'Image Menu Item (external)' 

a. The template will be displayed: 

 

b. Give the item a name. You may wish to use the same text as will 

appear to the user, so you can see which item is which in the content 

list. 

c. Type or paste in the link address (remember to include http:// or 

https://) in the 'External Link' box. 

d. Type the link text you want to use in the 'External Link Text' box. 

e. Click in the box next to Image to choose your image file. Alternatively 

drag the file from your computer onto the box. Make sure the image is 

the right size (336x388px) and that it is no bigger than 50kb in file 

size. When you have chosen your image, it will be displayed in the 

box. 

f. Click Save changes to finish. 
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21. 'Image Menu + Text Item (internal)' 

a. The template will be displayed: 

 

b. Give the item a name. You may wish to use the same text as will 

appear to the user, so you can see which item is which in the content 

list. 

c. Click the 'Add section link' button to choose the section you wish to 

link to. 

d. When you have chosen the section, it will be displayed beneath the 

Add section link button. 

e. You can use the name of the section you are linking to as the link text 

by leaving the 'Use default link text' tick box ticked. If you wish to use 

different wording, untick the box and type your chosen text in the 

'Enter custom link text' box which appears. 

f. Click in the box next to Image to choose your image file. Alternatively 

drag the file from your computer onto the box. Make sure the image is 

the right size (336x388px) and that it is no bigger than 50kb in file 

size. When you have chosen your image, it will be displayed in the 

box. 

g. Type the link text you want to use in the ‘Text’ box. This is limited to 

100 characters so that the text doesn’t cover too much of the image. 

h. Click Save changes to finish. 
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22. When you have finished adding your image menu items, return to the Site 

Structure. 

23. Click on the Actions button for the section where the image menu will 

appear. Choose 'Preview section'.  

24. Check that the image menu appears as you would like it to 

a. Image menu items without additional text: 

 

b. Image menu items with additional text: 

 

25. Remember that you will need to approve the content that you have created 

so that the new image menu to be displayed on the live webpage. 


