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Gwybodaeth bwysig
Roedd yr wybodaeth a gyhoeddir yn y llyfryn hwn am y rhaglenni gradd 
yn gywir pan anfonwyd y ddogfen i’w argraffu (Medi 2019), ond gellid ei 
newid. Cyn gwneud cais, rydym yn cynghori darpar fyfyrwyr i edrych ar 
ein gwefan i gael yr wybodaeth a’r manylion diweddaraf am y cwrs gan 
gynnwys ein gofynion mynediad, er mwyn bod yn sicr fod y cynllun yn 
addas i’w gofynion.
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Croeso

Croeso i’r Adran Gyfrifiadureg

Rydym yn falch o fod yn un o Adrannau Cyfrifiadureg 
hynaf y DU, sy’n parhau i arwain ym maes ymchwil 
technolegol a pharatoi graddedigion o’r safon uchaf.

Ymhlith ein meysydd ymchwil a datblygu y mae 
roboteg, deallusrwydd artiffisial, biowybodeg, 
prosesu delweddau, cyfathrebu drwy’r rhyngrwyd 
a pheirianneg meddalwedd – ac mae gennym 
gysylltiadau cryf â chwmnïoedd rhyngwladol mawr.

Mae’r rhan fwyaf o’n graddau yn cael eu hachredu 
gan y BCS (Sefydliad Siartredig TG) ar ran y Cyngor 
Peirianneg, a fydd yn rhoi mantais i chi mewn 
marchnad swyddi gystadleuol.

Mae Aberystwyth yn lle gwych i fod yn fyfyriwr. 
Lleolir y dref yng nghanol rhai o’r ardaloedd gwledig 
harddaf yn y DU, ac mae’r Brifysgol yn cynnig 
cyfleusterau chwaraeon, cymdeithasol a chymorth 
rhagorol. 

Pam Astudio 
Cyfrifiadureg
Wrth i’r byd ddibynnu fwyfwy ar ddatblygiadau 
technolegol, bydd perthnasedd Cyfrifiadureg yn parhau 
i dyfu. Mae Cyfrifiadureg yn chwarae rhan hanfodol 
mewn peirianneg, gwyddoniaeth, teithio, cyfryngau, 
cyfathrebu, masnach a llawer mwy. O ganlyniad, bydd 
y wybodaeth a’r sgiliau technegol y byddwch yn eu 
meithrin wrth astudio gyda ni yn berthnasol i ystod 
eang o ddiwydiannau hollol wahanol. 

Mae’r Adran Gyfrifiadureg yn rhoi pwyslais mawr ar 
ansawdd yr addysgu, yr amgylchedd dysgu a’r profiad 
diwylliannol y mae’n ei gynnig i fyfyrwyr; mi fyddwch yn 
rhan o gymdeithas glos a chynhwysol yma.

Mae gan fyfyrwyr a chyflogwyr barch mawr at ein 
cynlluniau gradd cyffrous sydd hefyd yn berthnasol 
i’r gweithle. Mae dewis blwyddyn integredig mewn 
diwydiant hefyd yn opsiwn ac anogwn ein myfyrwyr i 
wneud hynny. Mae ein graddedigion yn gallu dod o hyd 
i swyddi diddorol, sy’n talu’n dda ar ôl graddio.

Bydd ein graddau yn eich paratoi ar gyfer amrywiaeth 
o yrfaoedd yn cynnwys: Cynllunio Meddalwedd; 
Cyfathrebu a Rhwydweithio; Cymwysiadau 
Cyfrifiaduron; Datblygu Gwefannau; Ymgynghori a 
Rheoli TG; Dadansoddi a Datblygu Systemau.

32



Ein Cyrsiau
> BSc Artificial Intelligence and Robotics
> BSc Business Information Technology
> BSc Computer Graphics, Vision and Games
> BSc Computer Science
> BSc Computer Science and Artificial Intelligence
> BSc Data Science
> BEng Robotics and Embedded Systems Engineering
> BEng Software Engineering
> BSc Web Development

Cynlluniau Meistr Integredig 
> MComp Computer Science
> MEng Robitics and Embedded Systems Engineering
> MEng Software Engineering

Mae modiwlau craidd a strwythyr 
dysgu’r cwrs yn cynnwys: 

Blwyddyn 1
> Introduction to Computer Infrastructure
> Introduction to Programming
> Problems and Solutions
> Professional and Personal Development
> Programming Using an Object-oriented  
 Language

Blwyddyn 2
> Artificial Intelligence
> C and C++
> Modelling Persistent Data
> Program Design, Data Structures and
     Algorithms
> Robots and Embedded Systems
> Software Engineering

Blwyddyn 3
> Machine Learning
> Major Project
> Professional Issues in the Computing
     Industry
> Space Robotics
> Robotics Applications
> Ubiquitous Computing

Yn Aberystwyth ymdrechwn i ddatblygu eich gwybodaeth am y 
technolegau sylfaenol yn ogystal â’r sgiliau galwedigaethol sy’n 
gysylltiedig â Deallusrwydd Artiffisial a Roboteg. 

Bydd y radd hon yn rhoi sylfaen gref i chi mewn rhaglennu, dylunio meddalwedd 
a phensaernïaeth gyfrifiadurol; a byddwch hefyd yn arbenigo yn namcaniaeth 
deallusrwydd artiffisial a roboteg, mewn datblygu cymwysiadau ymarferol, ac yn 
yr offer sy’n helpu gwaith datblygu. Mae hyn yn agor llawer o lwybrau ar gyfer 
ein graddedigion ac yn creu amgylchedd dysgu dynamig y gall ein myfyrwyr 
ddarganfod eu potensial ynddo. 

Dyma rai o’r cyfleoedd arbenigol sydd ar gael ym maes Deallusrwydd Artiffisial a 
Roboteg yn Aberystwyth:

•  labordy roboteg penodol;
•  gweithdy roboteg;
•  pob math o offer ymchwil arbenigol gan gynnwys ceir trydan, crwydrwyr 

robotig, robotiaid hwylio, breichiau robotig, llwyfannau hedfan robotig.

Cyflogadwyedd
Mae’r radd hon yn darparu sgiliau priodol ar gyfer unrhyw swydd nodweddiadol 
yn y diwydiant meddalwedd. Mae pwyslais penodol y cwrs hefyd yn rhoi mantais 
i chi wrth ymgeisio am swyddi mewn meysydd fel roboteg ddiwydiannol neu 
ddeallusrwydd artiffisial; roboteg feddygol; rhaglennu cymwysiadau ‘softbot’ ar 
gyfer problemau masnachol; a dylunio a rhaglennu robotiaid deallus.

Artificial Intelligence  
and Robotics
BSc (Anrh)

Math o radd: BSc Cod UCA : GH76 (GH7P gyda blwyddyn 
integredig mewn diwydiant).

Hyd: 3 blynedd (mae GH7P yn 4 blynedd).
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Mae modiwlau craidd a strwythyr 
dysgu’r cwrs yn cynnwys: 

Blwyddyn 1
> Introduction to Computer Infrastructure
> Introduction to Programming
> Professional and Personal Development
> Programming Using an Object-oriented  
 Language
> Web Development Tools

Blwyddyn 2
> Business Systems Analysis
> Management Information Systems
> Modelling Persistent Data
> Programming for the Web 
> Applied Graphics
> Software Engineering for the Web
> Web Design and the User Experience

Blwyddyn 3
> Management of Organisations
> Web-based Major Project
> Professional Issues in the  
 Computing Industry

Trwy ddewis astudio’r radd Technoleg Gwybodaeth Busnes byddwch 
yn trwytho eich hun yn y dulliau technoleg a ddefnyddir gan weithwyr 
proffesiynol i ddatrys problemau busnes.  

Wrth weld yr elfennau allweddol ar gyfer sicrhau busnes effeithlon, gan gynnwys 
dadansoddi systemau, cymwysiadau cronfeydd data, amgylchedd busnes, systemau 
e-fasnach ac e-fusnes, rhaglennu a chyfarpar y we, byddwch yn dysgu’n gyflym sut i 
ddadansoddi anghenion busnesau a’u trosi’n systemau busnes effeithiol. 

Ar ôl cwblhau’r radd Technoleg Gwybodaeth Busnes yn llwyddiannus byddwch wedi 
meithrin y sgiliau a’r galluoedd craidd hanfodol y mae galw mawr amdanynt ymhlith 
cyflogwyr yn y maes hwn.

Dyma rai o’r cyfleoedd arbenigol sydd ar gael ym maes Technoleg Gwybodaeth Busnes 
yn Aberystwyth:

•  labordai sy’n cael eu diweddaru’n rheolaidd ac ynddynt ystod lawn o adnoddau 
cyfrifiadureg gan gynnwys MacOS, Linux a Windows;

•  modiwlau ar brosesau busnes, llunio gwefannau, HCI, ac e-fasnach.

Cyflogadwyedd
Mae gan ein graddedigion ddealltwriaeth dda o ofynion y byd masnachol o ran 
systemau cyfrifiadurol a ffordd broffesiynol o adeiladu’r systemau hynny o gydrannau 
safonol cronfeydd data, y we a meddalwedd swyddfa. Bydd y cynllun gradd hwn yn 
rhoi mantais i raddedigion sy’n ymgeisio am swyddi sy’n gofyn am adeiladu systemau 
masnachol gan ddefnyddio gwahanol offer a blociau adeiladu, defnyddio dulliau 
dadansoddol i gyflwyno TG er mwyn datrys problemau busnes, darparu atebion 
masnachol sy’n defnyddio cronfeydd data a’r we, a darparu cymorth i ddefnyddwyr TG.

Business Information 
Technology
BSc (Anrh)

Math o radd: BSc Cod UCAS: G500 (G501 gyda blwyddyn 
integredig mewn diwydiant).

Hyd: 3 blynedd (mae G501 yn 4 blynedd).

Mae modiwlau craidd a strwythyr 
dysgu’r cwrs yn cynnwys: 

Blwyddyn 1
> Introduction to Computer Infrastructure
> Introduction to Programming
> Problems and Solutions
> Professional and Personal Development
> Programming Using an Object-oriented  
 Language
> Web Development Tools

Blwyddyn 2
> Applied Graphics 
> Artificial Intelligence
> Modelling Persistent Data
> Program Design, Data Structures and
     Algorithms
> Software Engineering

Blwyddyn 3
> Computer Graphics and Games
> Computer Vision
> Machine Learning
> Major Project
> Professional Issues in the Computing
     Industry

Mae ein gradd Graffeg, Gweld a Gemau Cyfrifiadurol yn cyfuno 
cyfrifiadureg graidd â’r agwedd dechnegol ar y celfyddydau digidol. 

Bydd y cynllun hwn yn rhoi sylfaen gadarn i chi mewn rhaglennu, dylunio meddalwedd 
a phensaernïaeth cyfrifiaduron; a byddwch hefyd yn arbenigo yn y celfyddydau digidol. 
Mae ein cyrsiau yn cwmpasu’r agwedd dechnegol ar ddeall sut mae delweddau’n cael 
eu creu (graffeg cyfrifiaduron) a sut gall peiriannau ddeall a rhyngweithio â delweddau 
(gweld). Byddwch hefyd yn astudio gemau fideo, algorithmau craidd eu dyluniad, a sut 
maent yn cael eu gweithredu. 

Yn Aberystwyth mae ein staff yn gwneud ymchwil yn yr holl feysydd allweddol hyn 
felly gallant gynnig, gyda hyder a brwdfrydedd, sylfaen gref yn y technolegau sylfaenol 
yn ogystal â sgiliau galwedigaethol gan gynnwys rhaglennu, dylunio meddalwedd, 
chwilio am wybodaeth ac ymholiadau, dadansoddi data a’i ddosbarthu, a gwneud 
penderfyniadau deallus.

Dyma rai o’r cyfleoedd arbenigol sydd ar gael ym maes Graffeg, Gweld a Gemau 
Cyfrifiadurol yn Aberystwyth:

•  labordai sy’n cael eu diweddaru’n rheolaidd ac ynddynt ystod lawn o adnoddau 
cyfrifiadureg gan gynnwys MacOS, Linux a Windows;

•  cyfle i ddefnyddio’r offer ymchwil diweddaraf, gan gynnwys robotiaid symudol, 
robotiaid hwylio a breichiau llawdrin (manipulator), systemau olrhain symud a gweld, 
a labordy realiti rhithwir (VR);

•  darlithwyr sy’n gwneud ymchwil ym maes gweld cyfrifiadurol ac sy’n arbenigo ym 
meysydd y radd hon.

Cyflogadwyedd
Bydd graddedigion y radd hon yn arbennig o gymwys ar gyfer swyddi ym maes datblygu 
gemau, dadansoddi data a’i ddosbarthu, delweddu, prosesu delweddau a fideo. 
Byddwch hefyd yn dysgu’r wybodaeth sydd ei hangen mewn swyddi eraill ym maes 
dylunio meddalwedd, dadansoddi a datblygu systemau, cyfathrebu a rhwydweithio, 
datblygu’r we a gwaith ymgynghori TG.

Computer Graphics, 
Vision and Games
BSc (Anrh)

Math o radd: BSc Cod UCAS: G450 (G451 gyda blwyddyn 
integredig mewn diwydiant).

Hyd: 3 blynedd (mae G451 yn 4 blynedd).

76



Mae modiwlau craidd a strwythyr 
dysgu’r cwrs yn cynnwys:  

Blwyddyn 1
> Introduction to Computer Infrastructure
> Introduction to Programming
> Problems and Solutions
> Professional and Personal Development
> Programming Using an Object-oriented  
 Language
> Web Development Tools

Blwyddyn 2
> Modelling Persistent Data
> Program Design, Data Structures and
    Algorithms
> Software Engineering

Blwyddyn 3
> Agile Methodologies
> Major Project
> Professional Issues in the Computing 
    Industry

Mae ein cynllun gradd Cyfrifiadureg yn cwmpasu rhaglennu, 
systemau gweithredu cyfrifiadurol, cynllunio meddalwedd a 
pheirianneg systemau meddalwedd mawr, ac yn golygu mai dyma 
radd fwyaf hyblyg ein Hadran, sy’n darparu modiwlau craidd sy’n 
allweddol ar gyfer gyrfa ym maes Cyfrifiadureg. 

Cewch gyfle i ddysgu sgiliau arbenigol, megis peirianneg meddalwedd, graffeg a 
delweddu, deallusrwydd artiffisial, roboteg, telemateg, cyfrifiadura symudol, datblygu 
gwefannau a chyfrifiadura ffynhonnell agored y mae cyflogwyr y diwydiant yn chwilio 
amdanynt.

Yn Aberystwyth bydd ein myfyrwyr Cyfrifiadureg yn mwynhau:

•  labordai sy’n cael eu diweddaru’n rheolaidd ac ynddynt ystod lawn o adnoddau 
cyfrifiadureg gan gynnwys MacOS, Linux a Windows;

•  modiwlau craidd cyfrifiadureg a nifer fawr o fodiwlau dewisol;
•  cyfle i ddefnyddio’r offer diweddaraf, gan gynnwys robotiaid symudol, robotiaid 

hwylio a breichiau llawdrin (manipulator), systemau olrhain symud a gweld.

Cyflogadwyedd
Mae galw mawr am ein graddedigion a’n myfyrwyr blwyddyn mewn gwaith ymhlith 
cyflogwyr, gan gynnwys: y BBC, Google, Amadeus Germany GmbH, CAP Gemini, 
Ethos Digital Technology, Fidessa, Logica a Renishaw Plc. Ymhlith swyddi ein 
graddedigion mae: rhaglennydd dadansoddi, datblygwr meddalwedd graddedig, 
swyddog TG, rhaglennydd, cynorthwyydd ymchwil, peiriannydd meddalwedd, 
datblygwr systemau a dylunydd gwefannau.

Computer Science
BSc (Anrh)

Math o radd: BSc Cod UCAS: G400 (G401 gyda blwyddyn 
integredig mewn diwydiant).

Hyd: 3 blynedd (mae G401 yn 4 blynedd).

Mae modiwlau craidd a strwythyr 
dysgu’r cwrs yn cynnwys:  

Blwyddyn 1
> Introduction to Computer Infrastructure
> Introduction to Programming
> Problems and Solutions
> Professional and Personal Development
> Programming Using an Object-oriented  
 Language
> Web Development Tools

Blwyddyn 2
> Artificial Intelligence
> Modelling Persistent Data
> Program Design, Data Structures and
    Algorithms
> Software Engineering

Blwyddyn 3
> Agile Methodologies
> Machine Learning
> Major Project
> Professional Issues in the Computing
     Industry

Dros y blynyddoedd diwethaf daeth technegau Deallusrwydd Artiffisial 
(DA) yn gyffredin mewn diwydiant, ac o ganlyniad mae galw mawr 
am raddedigion cyfrifiadureg sydd â hyfforddiant penodol mewn 
Deallusrwydd Artiffisial. 

Byddwch yn datblygu sylfaen gadarn mewn sgiliau cyfrifiadura megis rhaglennu, dylunio 
meddalwedd, a phensaernïaeth cyfrifiaduron.  

Byddwch hefyd yn datblygu sgiliau arbenigol ym maes deallusrwydd artiffisial, sy’n 
gysylltiedig â meysydd astudio eraill, megis asiantau deallus ar gyfer rhaglennu gemau a 
chyfrifiadura symudol i ddatrys problemau cymhleth gan gynnwys dadansoddi, dylunio, 
dewis datrysiadau a’u rhoi ar waith. Mae galw mawr am y sgiliau hyn gan gyflogwyr, ac 
felly maent yn eich paratoi i lwyddo yn y dyfodol. 

Dyma rai o’r cyfleoedd arbenigol sydd ar gael ym maes Cyfrifiadureg a Deallusrwydd 
Artiffisial yn Aberystwyth:

•  labordy roboteg penodol;
•  modiwlau yn cynnwys Deallusrwydd Artiffisial, algorithmau a dysgu peirianyddol;
•  cyfle i ddefnyddio’r offer diweddaraf, gan gynnwys ceir trydanol, robotiaid symudol, 

robotiaid hwylio a breichiau llawdrin (manipulator), llwyfannau hedfan robotig.

Cyflogadwyedd
Mae’r radd hon yn darparu sgiliau priodol ar gyfer unrhyw swydd yn y diwydiant 
meddalwedd. Mae pwyslais penodol y cwrs hefyd yn rhoi mantais i chi wrth ymgeisio 
am swyddi mewn meysydd lle mae angen cymhwyso awtonomiaeth neu ddeallusrwydd 
artiffisial; tasgau meddygol a/neu fiowybodeg lle mae angen cefndir da mewn 
deallusrwydd cyfrifiadurol; rhaglennu cymwysiadau ‘softbot’ ar gyfer problemau 
masnachol/busnes; dylunio a gweithredu rheolyddion deallus, fel y rhai sydd eu hangen 
mewn roboteg.

Computer Science 
and Artificial Intelligence
BSc (Anrh)

Math o radd: BSc Cod UCAS: GG4R (GG47 gyda blwyddyn 
integredig mewn diwydiant).

Hyd: 3 blynedd (mae GG47 yn 4 blynedd).
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Mae modiwlau craidd a strwythyr 
dysgu’r cwrs yn cynnwys:  

Blwyddyn 1
> Algebra
> Calculus
> Introduction to Computer Infrastructure
> Introduction to Programming
> Profitability
> Further Algebra and Calculus
> Mathematical Analysis
> Programming Using an Object-oriented  
 Language
> Statistics

Blwyddyn 2
> Applied Statistics
> Distributions and Estimation
> Introduction to Numerical Analysis and its
    Applications
> Modelling Persistent Data
> Program Design, Data Structures and
    Algorithms
>  Linear Algebra
>  Software Engineering

Blwyddyn 3
> Agile Methodologies
> Linear Statistical Models
> Major Project

Mae gwyddor data yn ddisgyblaeth newydd gyffrous sy’n dod â 
chyfrifiadureg a mathemateg ynghyd, ac sy’n ymdrin â sut y gallwn wneud 
synnwyr o’r terabeitiau o wybodaeth y mae ein cyfrifiaduron yn eu casglu 
bob dydd. Gellir ei defnyddio i ddarogan yr hyn y bydd pobl am ei brynu, 
neu lle y mae angen rhoi mwy o arian yn y Gwasanaeth Iechyd Gwladol 
i’w wneud yn fwy effeithiol, er enghraifft.

Dysgir y cwrs ar y cyd rhwng yr Adran Cyfrifiadureg a’r Adran Fathemateg i annog syniadau 
o safon byd-eang ac ysgogi dysgu. Mae’r radd yn rhoi i chi sylfaen gref yn namcaniaeth 
sylfaenol gwyddor data yn ogystal â’r sgiliau ymarferol i chi allu cymhwyso’r ddamcaniaeth 
honno wrth ddadansoddi data yn y byd go iawn. 

Bydd y cynllun yn rhoi i chi ddealltwriaeth fathemategol ac ystadegol sylfaenol a’r sgiliau 
cyfrifiadureg ymarferol sydd eu hangen i allu dylunio a dadansoddi setiau data mawr, 
a nodi goblygiadau’r canlyniadau, gan roi i chi’r sgiliau sydd eu hangen i lwyddo yn y 
diwydiant.

Dyma rai o’r cyfleoedd arbenigol sydd ar gael ym maes Gwyddor Data yn Aberystwyth:

•  labordai sy’n cael eu diweddaru’n rheolaidd ac ynddynt ystod lawn o adnoddau 
cyfrifiadureg gan gynnwys MacOS, Linux a Windows;

•  modiwlau o’r ddwy adran sy’n canolbwyntio ar ymdrin â phatrymau mewn data;
•  darlithwyr y mae eu harbenigeddau ymchwil yn cynnwys ystadegau, dadansoddi data a 

modelu mathemategol.

Cyflogadwyedd
Mae prinder gwyddonwyr data sydd â’r sgiliau angenrheidiol ac o’r herwydd mae disgwyl y 
bydd galw mawr am raddedigion yn y maes hwn dros y blynyddoedd nesaf. Bydd gan ein 
graddedigion brofiad o’r ystadegau a’r gyfrifiadureg sydd eu hangen ar wyddonwyr data. 
Mae’r opsiwn blwyddyn mewn gwaith yn golygu y gallwch orffen eich gradd wedi cael 
blwyddyn o brofiad gwaith eisoes ym maes gwyddor data, a bydd hynny’n eich gwneud hyd 
yn oed yn fwy deniadol i gyflogwyr.

Data Science
BSc (Anrh)

Math o radd: BSc Cod UCAS: G400 (G401 gyda blwyddyn 
integredig mewn diwydiant).

Hyd: 3 blynedd (mae G401 yn 4 blynedd).

Mae modiwlau craidd a strwythyr 
dysgu’r cwrs yn cynnwys:  

Blwyddyn 1
> Algebra and Differential Equations
> Calculus
> Classical Dynamics
> Introduction to Programming
> Forces and Energy
> Problems and Solutions
> Professional and Personal Development
> Programming Using an Object-oriented  
 Language

Blwyddyn 2
> Mathematical Physics
> Program Design, Data Structures and
     Algorithms
> Sensors, Electronics and Instrumentation
> Artificial Intelligence
> Robots and Embedded Systems
> Software Engineering

Blwyddyn 3
> Major Project
> Professional Issues in the Computing
     Industry
> Robotics Applications
> Space Robotics

Bydd ein staff sy’n weithgar ym maes ymchwil yn darparu cymorth 
ymarferol i’ch helpu i adeiladu a chynnal systemau deallus a 
sicrhau dibynadwyedd mewn sefyllfaoedd anodd eu darogan yn 
y byd go iawn. Er mwyn gweithio yn y maes hwn mae’n rhaid wrth 
ddealltwriaeth ddofn o feddalwedd, ond dealltwriaeth hefyd o sut 
i weithredu hynny yn y byd ffisegol a’r fathemateg sylfaenol sy’n 
disgrifio hynny.

Yn ogystal â sylfaen gref o ran sgiliau cyfrifiadureg, yn y radd hon byddwch 
hefyd yn datblygu sgiliau arbenigol ym maes roboteg, Deallusrwydd Artiffisial a 
pheirianneg systemau. Mae ein blwyddyn mewn diwydiant (dewisol) yn ffordd 
allweddol o ennill profiad ymarferol o’r sgiliau a gafodd eu meithrin yn ystod dwy 
flynedd gyntaf yr astudio, a bydd hyn yn eich helpu chi i ddisgleirio yn y diwydiant.

Dyma rai o’r cyfleusterau arbenigol sydd ar gael i fyfyrwyr Roboteg a Peirianneg 
Systemau Mewnosodedig yn Aberystwyth:

•  labordy penodedig ar gyfer roboteg;
•  gweithdy roboteg;
•  ystod o offer ymchwil arbenigol gan gynnwys ceir trydan, crwydrwyr robotig, 

robotiaid hwylio, breichiau robotig, llwyfannau hedfan robotig.

Cyflogadwyedd
Bydd gan ein graddedigion gefndir cryf mewn cyfrifiadureg a ddylai eu paratoi 
ar gyfer llawer o swyddi yn y diwydiant cyfrifiadurol. Ar ben hynny, mae’r sgiliau 
penodol a ddysgir ar y cwrs gradd hwn yn rhoi sylfaen ddelfrydol ar gyfer gweithio 
yn y diwydiannau aerofod a modurol ac ym maes newydd Rhyngrwyd y Pethau.

Robotics and Embedded 
Systems Engineering
BEng (Anrh

Math o radd: BEng Cod UCAS: 132A (132B gyda blwyddyn 
integredig mewn diwydiant).

Hyd: 3 blynedd (mae 132B yn 4 blynedd).
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Mae modiwlau craidd a strwythyr 
dysgu’r cwrs yn cynnwys:  

Blwyddyn 1
> Introduction to Computer Infrastructure
> Introduction to Programming
> Problems and Solutions
> Professional and Personal Development
> Programming Using an Object-oriented  
 Language
> Web Development Tools

Blwyddyn 2
> C and C++
> Modelling Persistent Data
> Program Design, Data Structures and
     Algorithms
> Software Engineering

Blwyddyn 3
> Agile Methodologies
> Major Project
> Mobile Development with Android
> Mobile Development with iOS
> Professional Issues in the Computing
    Industry

Mae modiwlau craidd a strwythyr 
dysgu’r cwrs yn cynnwys:  

Blwyddyn 1
> Introduction to Computer Infrastructure
> Introduction to Programming
> Problems and Solutions
> Professional and Personal Development
> Programming Using an Object-oriented  
 Language
> Web Development Tools

Blwyddyn 2
> Modelling Persistent Data
> Programming forthe Web
> System and Network Services   
 Administration
> Software Engineering for the Web
> Web Design and the User Experience

Blwyddyn 3
> E-commerce Implementation,   
 Management and Security
> Web-based Major Project
> Professional Issues in the  
 Computing Industry

Mae peirianneg meddalwedd yn ymwneud â chynhyrchu systemau 
meddalwedd mawr o safon uchel sy’n aml yn hirhoedlog. Er mwyn 
gweithio yn y maes hwn mae’n rhaid datblygu dealltwriaeth drylwyr 
o feddalwedd a’r technolegau cysylltiedig, ynghyd â dealltwriaeth o’r 
materion rheoli a phroffesiynol sy’n gysylltiedig â datblygu systemau 
mawr.

Mae’r radd hon yn gosod pwyslais ar beirianneg broffesiynol yn ogystal â sgiliau cyfrifiadura.  
Yn ogystal â datblygu dealltwriaeth ddofn o feddalwedd a thechnolegau cysylltiedig, 
byddwch hefyd yn magu gwerthfawrogiad o’r materion rheoli a phroffesiynol sy’n gysylltiedig 
â datblygu systemau mawr. Byddwch yn datblygu sgiliau arbenigol mewn graffeg a 
delweddu, deallusrwydd artiffisial, roboteg, telemateg a chyfrifiadura symudol. 

Mae’r radd hon yn cynnwys blwyddyn integredig mewn diwydiant, pan gewch gyfle i roi eich 
sgiliau ar waith yn y byd go iawn, i herio eich hun ac i greu cysylltiadau amhrisiadwy o ran 
rhwydweithio. Mae llawer o’n myfyrwyr yn dychwelyd o’r flwyddyn hon gyda swyddi ar gyfer 
yr adeg pan fyddant yn graddio. 

Dyma rai o’r cyfleoedd arbenigol sydd ar gael ym maes Peirianneg Meddalwedd yn 
Aberystwyth:

•  labordai sy’n cael eu diweddaru’n rheolaidd ac ynddynt ystod lawn o adnoddau 
cyfrifiadureg gan gynnwys MacOS, Linux a Windows;

•  modiwlau craidd sy’n canolbwyntio ar sefyllfaoedd peirianneg meddalwedd;
•  darlithwyr â chysylltiadau agos â’r diwydiant meddalwedd. 

Cyflogadwyedd
Mae’r radd hon yn darparu sgiliau priodol ar gyfer y rhan fwyaf o swyddi technegol yn y 
diwydiant meddalwedd. Mae ein graddedigion wedi cael swyddi mewn cwmnïau bach a mawr 
a hefyd mewn cyrff llywodraethol, a chanmolir ein graddedigion yn aml am eu hagwedd 
broffesiynol. 

Mae galw mawr am weithwyr sydd â’r sgiliau i greu rhaglenni effeithiol 
ar y rhyngrwyd er mwyn cwrdd â gofynion busnes modern. Ar y radd 
hon rydym yn cyfuno hyfforddiant ymarferol ar gyfer creu gwefannau 
proffesiynol ag astudiaeth o gyd-destun masnachol, cyfreithiol a 
thechnegol y rhyngrwyd. 

Byddwch yn cael eich cyflwyno i gysyniadau ac offer sylfaenol Cyfrifiadureg megis 
rhaglennu, algorithmau, problemau a datrysiadau. Byddwch hefyd yn dysgu am isadeiledd 
cyfrifiaduron, mathemateg, rhaglennu ar gyfer y we, e-fasnach, gweinyddu systemau, 
a chronfeydd data. Byddwch yn datblygu eich sgiliau datblygu gwe a pheirianneg 
meddalwedd eich hun, ac yn eich blwyddyn olaf bydd gofyn ichi ddatblygu darn o 
feddalwedd mewn maes sydd o ddiddordeb penodol i chi ar gyfer eich prosiect unigol.  

Gallwch hefyd astudio’r cwrs hwn gyda blwyddyn mewn diwydiant, ac ar sail hynny bydd 
llawer o’n graddedigion yn cael cynnig swyddi wedi iddynt raddio. 

Dyma rai o’r cyfleoedd arbenigol sydd ar gael ym maes Datblygu i’r We yn Aberystwyth:

•  labordai sy’n cael eu diweddaru’n rheolaidd ac ynddynt ystod lawn o adnoddau 
cyfrifiadureg gan gynnwys MacOS, Linux a Windows;

•  modiwlau ar weinyddu systemau, adeiladu cymwysiadau’r we ar lefel manyleb 
ddiwydiannol, ac e-fasnach.

Cyflogadwyedd
Bydd ein graddedigion yn gallu mynd ati i adeiladu gwefannau mewn modd proffesiynol a 
byddant yn deall y broses fusnes sy’n sail i gymwysiadau masnachol y we, a bydd hyn yn 
rhoi mantais iddynt wrth ymgeisio am swyddi sy’n gofyn am adeiladu gwefannau modern 
sy’n seiliedig ar gronfeydd data gan ddefnyddio offer a chydrannau priodol; defnyddio’r 
we a chronfeydd data i ddarparu atebion rhyngweithiol amser real i ddiwydiant, masnach 
a’r sector gyhoeddus; datblygu atebion rhwydweithiol i sefydliadau; a chynorthwyo 
defnyddwyr cyfrifiaduron a rhwydweithiau.

Software Engineering
BEng (Anrh)

Web Development
BSc (Anrh)

Math o radd: BEng Cod UCAS: G600. Hyd: 4 blwyddyn (gan gynnwys blwyddyn 
integredig mewn diwydiant).

Math o radd: BSc Cod UCAS: H602 (H603 gyda blwyddyn 
integredig mewn diwydiant).

Hyd: 3 blynedd (mae H603 yn 4 blynedd).
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Mae ein cyrsiau MEng ac MComp uchel eu bri yn debyg i’r 
graddau Baglor cyfatebol ond maent yn cynnig blwyddyn 
ychwanegol o ddysgu ar lefel uwchraddedig ar ffurf gradd Meistr 
Integredig.

Mae Peirianneg Meddalwedd yn cynnwys blwyddyn integredig mewn diwydiant, yn 
wahanol i’r cynlluniau eraill lle gallwch ddewis gwneud blwyddyn integredig mewn 
diwydiant, sy’n golygu bod y cyrsiau’n para 5 mlynedd. Y flwyddyn integredig mewn 
diwydiant fydd trydedd flwyddyn eich cwrs, i’w dilyn gan ddwy flynedd ychwanegol o 
astudio i ddatblygu eich sgiliau ymhellach a’ch gwneud yn fwy cyflogadwy trwy ein 
dulliau dysgu cefnogol. Yn ystod yr amser hwn, byddwch yn ymgymryd â phrosiectau 
tîm ac unigol yn ogystal â modiwlau ar lefel Meistr. Mae heriau penagored yn gyfle i 
chi archwilio a phrofi’ch gwybodaeth, ac i lwyddo bydd angen meddwl annibynnol ac 
agwedd broffesiynol a threfnus tuag at eich astudiaethau. 

Caiff myfyrwyr Meistr Integredig yn Aberystwyth gyfle i fanteisio ar:

•  labordai sy’n cael eu diweddaru’n rheolaidd sy’n cynnwys pob math o adnoddau 
cyfrifiadura gan gynnwys MacOS, Linux a Windows;

•  darlithwyr â chysylltiadau agos â’r diwydiant meddalwedd ac ymchwil arloesol;
•  cyfle i ddefnyddio’r offer diweddaraf, gan gynnwys robotiaid symudol, breichiau 

llawdrin (manipulator), a systemau olrhain symud a gweld.

Cyflogadwyedd
Mae galw mawr am ein graddedigion ymhlith cyflogwyr, yn enwedig rheini â 
chymhwyster ar lefel Meistr. Mae’r flwyddyn mewn diwydiant yn golygu y gall myfyrwyr 
orffen eu gradd â blwyddyn o brofiad gwaith eisoes ym maes cyfrifiadura, sy’n eu 
gwneud hyd yn oed yn fwy deniadol i gyflogwyr.

Cynlluniau Gradd Meistr

Math o radd: MEng neu MComp.

Hyd: 5 blynedd (mae 132C a G409 yn 4 
blynedd).

G409, G419 a G601 yn unig

MComp Computer Science 
  (G409, G419 gan gynnwys blwyddyn integredig mewn diwydiant)   
MEng Robotics and Embedded Systems Engineering 

  (132C, 132D MEng gan gynnwys blwyddyn integredig mewn diwydiant) 
MEng Software Engineering (G601) 
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Ymchwil
Mae pob un o’n darlithwyr yn weithgar yn eu 
meysydd ymchwil ac yn mwynhau helpu myfyrwyr 
i ddatblygu eu gwybodaeth, eu dealltwriaeth 
a’u defnydd. Ceir pedwar grŵp ymchwil lle 
mae ein darlithwyr yn rhannu eu harbenigedd, 
yn genedlaethol ac yn rhyngwladol, ac anogir 
myfyrwyr sy’n rhannu’r un diddordebau i gymryd 
rhan. 

•  Y Grŵp Ymresymu Datblygedig – yn cynhyrchu 
gwaith ymchwil sy’n torri tir newydd ym 
meysydd diagnosis awtomataidd a dadansoddi 
methiant, ac yn dyfeisio technegau “fuzzy-
rough” ar gyfer fformiwleiddio a symleiddio 
modelau gwybodaeth;

•  Y Grŵp Biowybodeg a Bioleg Cyfrifiadureg – yn 
gwneud gwaith ymchwil mewn meysydd megis 
dadansoddi data biolegol ar raddfa fawr, ffurfioli 
data biolegol, gwybodeg biofeddygol, geneteg, 
ffarmacogenomeg a bioleg systemau;

•  Y Grŵp Roboteg Ddeallus – un o’r grwpiau 
roboteg mwyaf ac enwocaf yn y DU. Mae’n 
ymwneud â chonsortia ymchwil cenedlaethol 
a rhyngwladol o fodelau cyfrifiadurol newydd 
i deithiau gofodol i’r blaned Mawrth; mae’n 
canolbwyntio ar faterion meddalwedd a 
chaledwedd sy’n allweddol i “amgylcheddau 
digymell”

•  Y Grŵp Gweledigaeth, Graffeg a Delweddu 
– yn canolbwyntio ar ddadansoddi a deall 
delweddau (meddygol); echdynnu strwythur 
gwrthrychau cymhleth; dulliau yn seiliedig ar 
edrychiad wrth ddarparu robotiaid symudol â 
galluoedd amrywiol yn cynnwys mapio topolegol 
a sefydlogiad ystum; dadansoddi data lloeren 
aml-sbectrol at ddibenion amgylcheddol.

Ysgoloriaethau’r Adran

Rydym wedi ymrwymo i annog ymgeiswyr brwdfrydig o safon uchel i astudio 
Cyfrifiadureg. Dyna’r rheswm dros gynnig Ysgoloriaeth Adrannol i ymgeiswyr sy’n 
ennill graddau (A*) rhagorol yn Safon Uwch, neu gymwysterau perthnasol eraill.

Gwerth y wobr yw £500 y flwyddyn drwy gydol eich cynllun gradd (tair neu 
bedair blynedd), gan roi cyfanswm o hyd at £6,800 (os enillir Ysgoloriaeth 
Mynediad y Brifysgol ar ben hynny). Cewch gadw’r wobr ar yr amod eich bod 
yn sicrhau cyfartaledd o 70% yn eich arholiadau bob blwyddyn. Gall myfyrwyr 
anrhydedd cyfun ennill £250 y flwyddyn.

Mae gan yr Adran ryddid i gynnig gwobrau ychwanegol yn ogystal.
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Bywyd Adrannol ac 
Aberystwyth

Yr Hyn mae ein Myfyrwyr 
yn ei Ddweud

Mae Aberystwyth yn dref glan môr fywiog a chosmopolitan, sy’n cynnig 
llawer i’n myfyrwyr. Fe’i lleolir yng nghanol tirwedd drawiadol sy’n 
cynnwys y môr, traethau, dyffrynnoedd a bryniau; mae’n lle unigryw i 
fyw ac astudio. 

Ochr yn ochr â’ch astudiaethau Cyfrifiadureg, anogwn ein holl fyfyrwyr 
i ymuno â’r gwahanol glybiau a chymdeithasau y mae’r Brifysgol yn eu 
darparu. Ceir sawl cymdeithas a chlwb sy’n gysylltiedig â Chyfrifiadureg, 
megis:

• AberCompSoc – mae ein cymdeithas myfyrwyr cyfrifiadureg yn trefnu 
digwyddiadau a theithiau addysgiadol rheolaidd, yn ogystal â’r noson 
gymdeithasol wythnosol. 

• Cymdeithas Chwaraewyr Gemau Aberystwyth – cymdeithas sy’n frwd 
wrth ddarparu llwyfan cymdeithasol a chystadleuol i chwaraewyr 
gemau Aberystwyth. Mae’r Gymdeithas yn cynnal digwyddiadau 
gemau yn rheolaidd yn undeb y myfyrwyr, yn trefnu nosweithiau 
cymdeithasol wythnosol yn y dref ac yn cystadlu’n genedlaethol 
â phrifysgolion eraill. Yn ystod y blynyddoedd diwethaf, mae’r 
Gymdeithas wedi parhau i ehangu ac mae hi bellach yn un o’r 
cymdeithasau mwyaf, a’r mwyaf llwyddiannus, yn Aberystwyth. 

• Clwb Roboteg Aberystwyth – gyda chymorth yr Arddangosfa Infinity a 
Chlwb Roboteg Aberystwyth (ymestyn allan), mae’r gymdeithas hon yn 
cwrdd bob prynhawn Mercher i gydweithio fel grwpiau neu unigolion 
i greu caledwedd a meddalwedd ar gyfer pob dim sy’n gysylltiedig â 
robotiaid. Ni fydd angen profiad arnoch, dim ond brwdfrydedd!

Robert Buchan Terrey
BSc Computer Science (G400), 2015-2018

Roeddwn i’n hoff o’r gymysgedd o astudio 
damcaniaethau a’r gwaith ymarferol ar y 
cwrs. Mae’r gwaith prosiect yn rhoi cyfle i 

chi ddysgu pethau dros eich hun, yn ogystal 
â dysgu sut i ddatrys problemau. Bydd y 

sgiliau yma’n ddefnyddiol iawn yn y gweithle. 
Dwi’n nawr yn gallu ysgrifennu cod i wirio 

moduron rheolyddion perfformwyr dwys, gan 
ddefnyddio iaith sydd o safon ddiwydiannol, 
yn defnyddio’r sgiliau datblygais ar y cwrs.

Samantha Pendleton 
BSc Business Information Technology (G500)  
ac yna MSc Data Science (G490), 2014-2018

Dwi’n hoff iawn o weithio gyda data, ac mae’r cwrs Meistr yma wedi 
dangos i mi sut gallai gyfuno rhaglennu gyda dadansoddi ystadegol 

o wyddor data! Roeddwn yn poeni i ddechrau byddai fy niffyg sgiliau 
rhaglennu yn amharu ar fy nysgu, ond mae’r ffyrdd arloesol maen 

nhw’n defnyddio yma i ddysgu wedi ei wneud yn hawdd i mi ddod yn 
wyddonydd data. 

Roeddwn i’n hoff iawn o’r darlithoedd byw ar godio Python, a bu i’r 
traethawd hir fy ngalluogi i ymchwilio gwahanol agweddau ar ddata 

gwyddonol. Yr Adran Cyfrifiadureg oedd fy nghartref drwy gydol y cwrs 
Meistr! Roedd yno ddigon o ofod cyfforddus i weithio ynddynt, ac roedd 

gennai’r holl adnoddau roedd angen. Roeddwn i’n hoff iawn o weithio 
yn llyfrgell Adeilad y Gwyddorau Ffisegol, ac roedd iddi olygfa wych!

Mae astudio Gwyddor Data wedi creu nifer o gyfleoedd i mi, ac yn 
bennaf oll mae’r cwrs wedi fy ysgogi i astudio’n bellach, a dwi nawr yn 
astudio am PhD mewn Biowybodeg Clinigol. Dwi’n gweithio gyda data 

cleifion clinigol gan chwilio am batrymau a thueddiadau, ac yn gweithio 
gyda grwpiau o gleifion wrth ddadansoddi’n bellach. Gobeithio bydd 

fy ngwaith yn cyfrannu at well ymchwil meddygol drwy uno casgliadau 
mawr o setiau data testunol i’w gwneud nhw’n fwy defnyddiol.
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Sut i wneud cais
Pan fyddwch wedi penderfynu pa gwrs yr hoffech ei astudio a ble, 
gallwch ddechrau’r broses o ymgeisio. Dyma gipolwg byr o’r broses a’n 
gweithdrefnau yma yn Aberystwyth.

1 Gwneud cais trwy  
UCAS.com

Dyddiad cau 15 Ionawr. Cod sefydliad Prifysgol 
Aberystwyth: A40
GAIR I GALL: Cewch rif UCAS 10 digid. Cadwch 
hwn wrth law oherwydd gofynnir am y rhif nifer 
o weithiau.

5 Llety 

Pan fyddwch wedi gwneud eich dewis cadarn/
wrth gefn gallwch wneud cais am lety (1 Ebrill 
ymlaen).

3 Bydd y cynnig i’w weld ar 
UCAS Track

2 Bydd y brifysgol yn 
ystyried eich cynnig

GAIR I GALL: Defnyddiwch UCAS Track i gadw 
llygad ar eich cais. Yn Aberystwyth rydym yn 
ceisio gwneud penderfyniad o fewn 4 wythnos.

6 Diwrnod y canlyniadau  

Bydd UCAS Track yn cadarnhau eich cynnig 
o le. Os nad ydych yn sicr beth yw’r cynnig, 
cysylltwch â’r brifysgol yn uniongyrchol. 
Gwnewch yn sicr nad ydych ar wyliau ar 
ddiwrnod y canlyniadau. Os nad ydych yn cael y 
graddau yr oeddech wedi gobeithio amdanynt, 
efallai yr hoffech ystyried y broses Glirio

4 Penderfynwch ble i fynd 

Pan fyddwch wedi cael eich holl gynigion, bydd 
angen i chi benderfynu i ba brifysgol yr hoffech 
fynd, o fewn amser penodol. Dyma pryd y 
bydd angen i chi nodi pa brifysgolion fydd eich 
dewisiadau cadarn ac wrth gefn.

7 Dechreuwch bacio!
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