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Important information
The programme information published in this brochure was correct at time 

of going to print (September 2019) and may be subject to change. Prospective 
students are advised to check the definitive programme information, including 

entry requirements, that is available on our website before making an 
application, to ensure that the programme meets their needs.
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Introduction

Welcome to the Department of Computer Science.

We are proud to be one of the longest established 
Computer Science Departments in the UK, 
continuing to lead in technological research  
and in the delivery of top quality graduates. 

Our areas of research and development include 
robotics, artificial intelligence, bioinformatics, 
image processing, internet communications and 
software engineering – with strong links with major 
international companies.

Most of our degrees are accredited by The  
Chartered Institute for IT (BCS) on behalf of the 
Engineering Council, giving you a head start  
when you enter the competitive job market. 

With an Athena SWAN Bronze award, we are 
committed to promoting gender equality across  
our department and advancing the careers of  
women in science and technology. 

Aberystwyth is a fantastic place to be a student. 
The town is set amongst some of the most beautiful 
countryside in the UK, and the University offers 
excellent sporting, social and support facilities.

Why study  
Computer Science
As the world becomes increasingly reliant on 
technological advancements, the relevancy of 
Computer Science will continue to grow. Computer 
Science plays an integral part in engineering, science, 
travel, media, communication, commerce and more. 
This means the knowledge and technical skills you  
will gain as you study with us are widely applicable  
to a number of vastly different industries.

The Department of Computer Science places great 
importance on the quality of teaching, learning 
environment and the cultural experience it offers its 
students; where you will become part of a close-knit 
and inclusive community.

Our exciting and workplace relevant degree schemes 
are highly regarded by both students and employers; 
with the option of an integrated year in industry  
which we strongly encourage our students to take.  
Our graduates are able to find interesting, well-paid 
work after graduation.

Our degrees will prepare you for a variety of careers 
that include: Software Design; Communications and 
Networking; Computer Applications; Web Development; 
IT Consultancy and Management; Systems Analysis  
and Development. 
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Our Courses
> BSc Artificial Intelligence and Robotics
> BSc Business Information Technology
> BSc Computer Graphics, Vision and Games
> BSc Computer Science
> BSc Computer Science and Artificial Intelligence
> BSc Data Science
> BEng Robotics and Embedded Systems Engineering
> BEng Software Engineering
> BSc Web Development

Integrated Master’s Schemes 

> MComp Computer Science
> MEng Robitics and Embedded Systems Engineering
> MEng Software Engineering

Core Modules and teaching 
structure on this course includes: 

Year 1
> Introduction to Computer Infrastructure
> Introduction to Programming
> Problems and Solutions
> Professional and Personal Development
> Programming Using an Object-oriented  
 Language

Year 2
> Artificial Intelligence
> C and C++
> Modelling Persistent Data
> Program Design, Data Structures and
     Algorithms
> Robots and Embedded Systems
> Software Engineering

Year 3
> Machine Learning
> Major Project
> Professional Issues in the Computing
     Industry
> Space Robotics
> Robotics Applications
> Ubiquitous Computing

At Aberystwyth we’ll help you to develop your knowledge of 
the underlying technologies, and the vocational skills involved 
with Artificial Intelligence and Robotics. 

This degree will give you a firm foundation in programming, software design 
and computer architecture; and you’ll also specialise in the theory of artificial 
intelligence and robotics, the development of practical applications, and tools that 
assist development. This opens up many pathways for our graduates and creates a 
dynamic learning environment in which our students can discover their potential.

At Aberystwyth Artificial Intelligence and Robotics students have access to:
•  a dedicated robotics laboratory;
•  a robotics workshop;
•  a range of specialised research equipment including electric cars, robotic 

rovers, sailing robots, robotic arms, UAVs.

Employability
This degree provides the appropriate skills for any typical job in the software 
industry. Its particular emphasis also gives you a head start when applying for 
jobs in areas like industrial robotics or machine learning; medical robotics; 
programming of softbot applications for commercial problems; and intelligent 
robotic design and programming.

Artificial Intelligence  
and Robotics
BSc (Hons)

Degree type: BSc UCAS Code: GH76 (GH7P with integrated 
year in industry).

Duration: 3 years (GH7P is 4 years).
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Core Modules and teaching 
structure on this course includes: 

Year 1
> Introduction to Computer Infrastructure
> Introduction to Programming
> Professional and Personal Development
> Programming Using an Object-oriented  
 Language
> Web Development Tools

Year 2
> Business Systems Analysis
> Management Information Systems
> Modelling Persistent Data
> Programming for the Web 
> Applied Graphics
> Software Engineering for the Web
> Web Design and the User Experience

Year 3
> Management of Organisations
> Web-based Major Project
> Professional Issues in the  
 Computing Industry

In choosing to study this Business Information Technology degree 
you’ll become skilled in the ways in which professionals apply 
technology to answer business problems.

With exposure to the key building blocks for business efficiency, including systems 
analysis, database applications, business environment, e-commerce and e-business 
systems, web programming and web tools, you will learn how to analyse business 
requirements and translate them into effective business systems. 

On successful completion of the Business Information Technology degree you’ll have 
amassed the range of core and essential skills and capabilities sought by employers of 
this discipline.

At Aberystwyth, Business Information Technology students have access to:
•  regularly updated laboratories providing access to a full range of computing 

environments including MacOS, Linux and Windows;
•  modules on business processes, building websites, HCI, and e-commerce.

Employability
Our graduates have a good understanding of the demands of the commercial world 
for computer systems and a professional approach to building those systems from 
standard database, web and office components. The scheme will provide an advantage 
when applying for jobs involving the creation of commercial systems using different 
tools and building blocks, using analytical techniques to introduce Information 
Technology (IT) into business problem solving, providing database and web-enabled 
commercial solutions, and supporting IT users.

Business Information 
Technology
BSc (Hons)

Degree type: BSc UCAS Code: G500 (G501 with integrated 
year in industry).

Duration: 3 years (G501 is 4 years).

Core Modules and teaching 
structure on this course includes: 

Year 1
> Introduction to Computer Infrastructure
> Introduction to Programming
> Problems and Solutions
> Professional and Personal Development
> Programming Using an Object-oriented  
 Language
> Web Development Tools

Year 2
> Applied Graphics 
> Artificial Intelligence
> Modelling Persistent Data
> Program Design, Data Structures and
     Algorithms
> Software Engineering

Year 3
> Computer Graphics and Games
> Computer Vision
> Machine Learning
> Major Project
> Professional Issues in the Computing
     Industry

Our Computer Graphics, Vision and Games degree combines core 
computer science with the technical end of digital arts. 

This scheme will give you a firm foundation in programming, software design and 
computer architecture; and you’ll also specialise in digital arts. Our courses cover the 
technical side of understanding how images are created (computer graphics) and how 
machines can understand and interact with images (vision). You will also study video 
games, their design core algorithms and implementation.

At Aberystwyth our staff actively research in these crucial areas so they can confidently 
and passionately give you a sound grounding in the underlying technologies as well as 
vocational skills that include programming, software design, information search and 
query, data analysis and classification, and intelligent decision-making. 

At Aberystwyth our Computer Graphics, Vision and Games students have access to:
•  regularly updated laboratories providing access to a full range of computing 

environments including MacOS, Linux and Windows;
• use of research equipment, including mobile robots, sailing robots and manipulator 

arms, vision and motion tracking systems and a VR laboratory;
• lecturing staff who are active in computer vision research and specialise in the areas 

of this degree.

Employability
Graduates of this degree will be particularly well-suited to jobs in games development, 
data analysis and classification, visualisation, image and video processing. You will also 
gain the knowledge needed for other roles in software design, systems analysis and 
development, communications and networking, web development and IT consultancy.

Computer Graphics, 
Vision and Games
BSc (Hons)

Degree type: BSc UCAS Code: G450 (G451 with integrated 
year in industry).

Duration: 3 years (G451 is 4 years).
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Core Modules and teaching 
structure on this course includes: 

Year 1
> Introduction to Computer Infrastructure
> Introduction to Programming
> Problems and Solutions
> Professional and Personal Development
> Programming Using an Object-oriented  
 Language
> Web Development Tools

Year 2
> Modelling Persistent Data
> Program Design, Data Structures and
    Algorithms
> Software Engineering

Year 3
> Agile Methodologies
> Major Project
> Professional Issues in the Computing 
    Industry

Computer Science covers a vast range of topics including 
programming, software design, and the engineering of large 
software systems; meaning it is our Department’s most flexible 
degree, providing core modules that are key for a career in 
Computer Science.

You will acquire specialist skills such as software engineering, graphics and 
visualisation, artificial intelligence, robotics, telematics, mobile computing, web 
development and open source computing, that are highly sought after by employers 
in this industry.

At Aberystwyth our Computer Science students have access to:
•  regularly updated laboratories providing access to a full range of computing 

environments including MacOS, Linux and Windows;
•  core modules in computer science and a wide range of optional modules;
•  use of research equipment, including mobile robots, sailing robots and 

manipulator arms, vision and motion tracking systems.

Employability
Our graduates and industrial year students are eagerly sought by employers. These 
include: the BBC, Google, Amadeus Germany GmbH, CAP Gemini, Ethos Digital 
Technology, Fidessa, Logica and Renishaw Plc. Example jobs entered include: analyst 
programmer, graduate software developer, IT officer, programmer, research assistant, 
software engineer, systems developer and website designer.

Computer Science
BSc (Hons)

Degree type: BSc UCAS Code: G400 (G401 with integrated 
year in industry).

Duration: 3 years (G401 is 4 years).

Core Modules and teaching 
structure on this course includes: 

Year 1
> Introduction to Computer Infrastructure
> Introduction to Programming
> Problems and Solutions
> Professional and Personal Development
> Programming Using an Object-oriented  
 Language
> Web Development Tools

Year 2
> Artificial Intelligence
> Modelling Persistent Data
> Program Design, Data Structures and
    Algorithms
> Software Engineering

Year 3
> Agile Methodologies
> Machine Learning
> Major Project
> Professional Issues in the Computing
     Industry

In recent years, Artificial Intelligence (AI) techniques have become 
common place in industry, as a result, there is a strong demand 
for computer science graduates who have specialist training in 
Artificial Intelligence. 

You will gain a firm foundation in computing skills such as programming, software 
design, and computer architecture. 

You will also develop specialised skills in the area of artificial intelligence, and 
interaction with related areas of study such as intelligent agents in games programming 
and mobile computing to solve complex problems including, analysis, design, solution 
choice and implementation. These skills are highly sought out by employers, equipping 
you for future success.

At Aberystwyth our Computer Science and Artificial Intelligence students have access 
to:
•  a dedicated robotics laboratory;
•  modules including AI, algorithms and machine learning;
•  a range of specialised research equipment including electric cars, robotic rovers, 

sailing robots, robotic arms, flying robotic platforms.

Employability
This degree provides the appropriate skills for any typical job in the software industry. 
It also gives you a head start when applying for jobs in application areas requiring 
autonomy or artificial intelligence; medical and/or bioinformatics tasks that require a 
good background in computational intelligence; programming of softbot applications 
for commercial/business problems; and design and implementation of intelligent 
controllers, such as those required in robotics.

Computer Science 
and Artificial Intelligence
BSc (Hons)

Degree type: BSc UCAS Code: GG4R (GG47 with integrated 
year in industry).

Duration: 3 years (GG47 is 4 years).
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Core Modules and teaching 
structure on this course includes: 

Year 1
> Algebra
> Calculus
> Introduction to Computer Infrastructure
> Introduction to Programming
> Profitability
> Further Algebra and Calculus
> Mathematical Analysis
> Programming Using an Object-oriented  
 Language
> Statistics

Year 2
> Applied Statistics
> Distributions and Estimation
> Introduction to Numerical Analysis and its
    Applications
> Modelling Persistent Data
> Program Design, Data Structures and
    Algorithms
>  Linear Algebra
>  Software Engineering

Year 3
> Agile Methodologies
> Linear Statistical Models
> Major Project

Data Science is an exciting new discipline where computing and 
mathematics meet, that addresses how we can make sense of the 
terabytes of information that our computers are collecting every day. 
It can be used to predict what people will want to buy or where we 
need to put more money into the National Health Service to make it 
more effective, for example.

Taught jointly by research-active academics in the Department of Computer Science and 
the Department of Mathematics to promote world-class ideas and stimulate learning, this 
degree gives you a strong grounding in the underlying theory of data science as well as the 
practical skills to be able to apply that theory in real-world data analytics. 

We provide you with the underlying mathematical and statistical understanding and the 
practical computing skills needed to be able to design and carry out analysis of large sets 
of data, and to draw implications from the results, giving you the skills needed to succeed 
in this industry.

At Aberystwyth our Data Science students have access to:
•  regularly updated laboratories providing access to a full range of computing 

environments including MacOS, Linux and Windows;
•  modules from both departments that focus on dealing with patterns in data;
•  lecturers whose research specialties include statistics, data analysis and mathematical 

modelling.

Employability
Our graduates and industrial year students are eagerly sought by employers. These include: 
the BBC, Google, Amadeus Germany GmbH, CAP Gemini, Ethos Digital Technology, 
Fidessa, Logica and Renishaw Plc. Example jobs entered include: analyst programmer, 
graduate software developer, IT officer, programmer, research assistant, software engineer, 
systems developer and website designer.

Data Science
BSc (Hons)

Degree type: BSc UCAS Code: G400 (G401 with integrated 
year in industry).

Duration: 3 years (G401 is 4 years).

Core Modules and teaching 
structure on this course includes: 

Year 1
> Algebra and Differential Equations
> Calculus
> Classical Dynamics
> Introduction to Programming
> Forces and Energy
> Problems and Solutions
> Professional and Personal Development
> Programming Using an Object-oriented  
 Language

Year 2
> Mathematical Physics
> Program Design, Data Structures and
     Algorithms
> Sensors, Electronics and Instrumentation
> Artificial Intelligence
> Robots and Embedded Systems
> Software Engineering

Year 3
> Major Project
> Professional Issues in the Computing
     Industry
> Robotics Applications
> Space Robotics

Our research-active staff provide hands-on support to guide 
you through building and running intelligent systems while 
ensuring reliability in unpredictable real-world situations. 
Work in this area requires not only a deep understanding of 
software, but also of the operation in the physical world and 
the underlying mathematics describing it.

As well as gaining a firm foundation in computing skills, you will develop 
specialised skills in robotics, Artificial Intelligence and systems engineering.  
Our optional year in industry is a crucial way for you to gain practical experience 
of applying the skills acquired in the first two years of study. It will also help you 
stand out from your competitors when you’re applying for work.

At Aberystwyth our Robotics and Embedded Systems Engineering students have 
access to:
•  dedicated robotics laboratory;
•  robotics workshop;
•  a range of specialised research equipment including electric cars, robotic 

rovers, sailing robots, robotic arms, flying robotic platforms.

Employability
Graduates will have a strong background in computing that should prepare them 
for a range of careers in the computing industry. In addition, the specific skills 
gained on this degree are an ideal preparation for working in the aerospace and 
automotive industries and the emerging area of the Internet of Things.

Robotics and Embedded 
Systems Engineering
BEng (Hons)

Degree type: BEng UCAS Code: 132A (132B with integrated 
year in industry).

Duration: 3 years (132B is 4 years).
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Core Modules and teaching 
structure on this course includes: 

Year 1
> Introduction to Computer Infrastructure
> Introduction to Programming
> Problems and Solutions
> Professional and Personal Development
> Programming Using an Object-oriented  
 Language
> Web Development Tools

Year 2
> C and C++
> Modelling Persistent Data
> Program Design, Data Structures and
     Algorithms
> Software Engineering

Year 3
> Agile Methodologies
> Major Project
> Mobile Development with Android
> Mobile Development with iOS
> Professional Issues in the Computing
    Industry

Core Modules and teaching 
structure on this course includes: 

Year 1
> Introduction to Computer Infrastructure
> Introduction to Programming
> Problems and Solutions
> Professional and Personal Development
> Programming Using an Object-oriented  
 Language
> Web Development Tools

Year 2
> Modelling Persistent Data
> Programming forthe Web
> System and Network Services   
 Administration
> Software Engineering for the Web
> Web Design and the User Experience

Year 3
> E-commerce Implementation,   
 Management and Security
> Web-based Major Project
> Professional Issues in the  
 Computing Industry

Software Engineering is concerned with the production of large, 
high-quality, and often long-lived, software systems. Work in this 
area requires not only a deep understanding of software and related 
technologies, but also an appreciation of the management and 
professional issues associated with the development of large systems. 

We emphasise professional engineering as well as computing skills on this degree. As well as 
developing a deep understanding of software and related technologies, you’ll also appreciate 
the management and professional issues associated with the development of large systems. 
You will develop specialised skills in graphics and visualisation, artificial intelligence, 
robotics, telematics and mobile computing. 

This degree includes an integrated year in industry, on which you’ll be able to acquire real-
world experience, to challenge yourself and create invaluable networking connections. Many 
of our students return from this year with employment for when they graduate.

At Aberystwyth our Software Engineering students have access to:
•  regularly updated laboratories providing access to a full range of computing environments 

including MacOS, Linux and Windows;
• core modules that focus on software engineering scenarios;
• lecturers with close links to the software industry.

Employability
This degree provides appropriate skills for the majority of technical jobs in the software 
industry. Graduates have obtained positions in companies both large and small and also  
in government bodies, and our graduates are frequently complimented on their  
professional approach.

There is a huge demand for graduates with the skills to construct 
effective internet applications to meet modern business needs. 
On this degree, we combine practical training in building websites 
to professional standards with study of the commercial, legal and 
technical context in which the internet operates.

You will be introduced to the fundamental concepts and tools of Computer Science such 
as programming, algorithms, problems and solutions. You’ll also learn about computer 
infrastructure, mathematics, web programming, e-commerce, systems administration, and 
databases. You’ll develop your web development and software engineering skills, and in 
your final year, you will be required to develop a piece of software in an area of particular 
interest for your individual project.

You can also study this course with a year in industry, from which many of our graduates 
are offered employment upon their graduation.

At Aberystwyth our Web Development students have access to:
•  regularly updated laboratories providing access to a full range of computing 

environments including MacOS, Linux and Windows;
•  modules on systems administration, building industrial specification level web 

applications, and e-commerce.

Employability
A professional approach to website construction and a good understanding of the business 
processes behind commercial web applications will give graduates an advantage when 
applying for jobs that entail building modern database-driven websites using appropriate 
tools and components; using the web and databases to provide interactive real-time 
solutions for industry, commerce and the public sector; developing network solutions for 
organisations; and supporting computer and network users.

Software Engineering
BEng (Hons)

Web Development
BSc (Hons)

Degree type: BEng UCAS Code: G600. Duration: 4 years (with integrated year in 
industry).

Degree type: BSc UCAS Code: H602 (H603 with integrated 
year in industry).

Duration: 3 years (H603 is 4 years).
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MComp Computer Science   
 (G409, G419 with integrated year in industry)  p8
 
MEng Robotics and Embedded Systems Engineering 
 (132C, 132D MEng with integrated year in industry)  p11

 
MEng Software Engineering (G601)    p12

Our prestigious MEng and MComp courses are similar to  
their equivalent Bachelor degrees but provide an extra year  
of instruction at postgraduate level in the form of an  
Integrated Master’s.

Software Engineering includes an integrated year in industry, while for the other 
schemes you may opt to take an integrated year in industry, taking courses to 5 years 
in length. The integrated year in industry forms the third year of your course, followed 
by a further two years of study to develop your skills and employability further with 
our supportive teaching. During this time, you will undertake team and individual 
projects as well as modules at Master’s level. Open-ended challenges are a chance 
for you to explore and test your knowledge, and success demands an independent-
minded, but nonetheless strictly professional and well-organised approach to study. 

At Aberystwyth our Integrated Master’s students have access to: 

•  regularly updated laboratories providing access to a full range of computing 
environments including MacOS, Linux and Windows;

•  lecturers with close links to the software industry and cutting-edge research;
•  research equipment, including mobile robots, manipulator arms, and vision and 

motion tracking systems.

Employability
Our graduates are eagerly sought by employers, particularly with a Master’s-level 
qualification. The year in industry means that students can finish their degree having 
already had a year’s experience of working in computing, making them even more 
attractive to employers.

Integrated Master’s schemes

Degree type: MEng or MComp.

Duration: 5 years (132C and G409 are 4 
years).

G409, G419 and G601 only
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Research
Many of our lecturers are research-active in 
their respective fields and enjoy helping students 
develop in their knowledge, understanding and 
application. There are four research groups where 
our lecturers use their expertise, nationally and 
internationally, and students that share the same 
interests are encouraged to get involved.

• Advanced Reasoning Group – conducting 
innovative research in qualitative and 
approximate reasoning, including methods of 
knowledge representation, model generation 
and refinement, and model-based problem 
solving; evolutionary computation and heuristic 
optimisation, including theoretical foundations 
of advanced computational intelligence 
techniques; 

• Bioinformatics and Computational Biology 
Group – conducting research in areas such 
genomics/metagenomics, health informatics, 
metabolomics, information management 
systems, time series analysis and stringology;

• Intelligent Robotics – the largest robotics 
group in Wales, involved in both national and 
international research consortia from novel 
computational models inspired by biology 
to space missions to Mars; focusing on both 
software and hardware issues that are key to 
‘unconstrained environments’; 

• Vision, Graphics and Visualisation Group 
– focussing on: medical image analysis and 
understanding; vision for biological analysis 
of plants and animals; vision for robotics, 
including navigation and object manipulation; 
understanding of human vision; and, 
applications of virtual and augmented reality.

Departmental Scholarship

We are committed to encouraging high-calibre and enthusiastic applicants 
to pursue studies in Computer Science. That is why we offer a Departmental 
Scholarship for applicants who achieve excellent (A*) grades on their A-Levels, 
or other relevant qualifications.

The level of the award is £500 per year for the duration of your degree scheme 
(three or four years giving a total award of up to £6,800 (if a University Entrance 
Scholarship is included on top). The award is retained providing that an exam 
average of 70% or above is achieved each year. Joint honours students are 
eligible for £250 per year.

Additional awards may also be made at the discretion of the Department.
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Departmental Life  
and Aberystwyth

What our students say

Aberystwyth is a vibrant and cosmopolitan seaside town, with lots to 
offer our students. Situated in a stunning landscape including sea, 
beach, valleys and hills it is a unique place to live and study.

Alongside your studies in Computer Science we encourage all our 
students to explore the various clubs and societies that the University 
offers. There are several societies and clubs that are related the 
Computer Science, such as:

• AberCompSoc – our student computer science society organises 
regular events and trips, as well as weekly socials. 

• Aberystwyth Community Of Gamers (ACOG) – devoted to providing a 
social and competitive platform for the gamers of Aberystwyth. ACOG 
frequently holds gaming events in the student union, runs weekly 
socials around town and competes nationally with other universities. 
Over the last few years, ACOG has continued to grow and is now one 
of the largest and most successful societies in Aberystwyth. 

• Aberystwyth Robotics Club – supported by the Infinity Exhibition 
and Aberystwyth Robotics Club (outreach), this society meets every 
Wednesday afternoon to work together as groups or as individuals to 
create the hardware and software for all things robotics related. No 
experience is required, just enthusiasm!

Robert Buchan Terrey
BSc Computer Science (G400), 2015-2018

I liked how the course was a good mix  
of practical hands on work, and theory.  

The project work gives you a chance to self-
learn and troubleshoot. These skills come  
in useful once you’re in the workplace. I  
now write code to test high-performance 

motor controllers, using an industry standard 
language which I was able to learn from 
scratch using the skills from the course.

Samantha Pendleton 
BSc Business Information Technology (G500)  

then MSc Data Science (G490), 2014-2018

 I love data, and this Masters degree showed me how to combine 
programming and statistical analysis to study the science of data!  
I was worried that my previous lack of programming skills might  

have held me back, but the innovative methods of teaching made  
my transition into a data scientist an enjoyable experience.  

In particular, I enjoyed the live-coding Python module lectures,  
and also the dissertation process allowed me to branch out  

and explore different aspects of data science.

The computer science department was my home for the duration  
of my Masters! There were plenty of comfortable spaces to work  

and I had all the resources I needed. I loved working in the  
IMPACS library as the view is so nice!

Studying Data Science has opened so many doors for me,  
but ultimately this course inspired me to study further, so I am currently 
pursuing a PhD in Clinical Informatics. I work with clinical patient data: 

seeking out patterns, trends, and groups of patients  
for further analysis. Hopefully my work will help to improve  

medical research by linking together large collections  
of textual data to make them more usable.
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How to apply
Once you have decided what course you want to study and where, you’ll be able to start the university 
application process. Here’s a brief overview of the process and our procedures here at Aberystwyth.

1 Apply through  
UCAS.com

Deadline 15 January. Aberystwyth University institution 
code: A40. 

TOP TIP: You’ll be given a 10 digit UCAS ID number. 
Keep this to hand as you’ll be asked for it many times.

5 Accommodation 

Once you’ve chosen your firm/insurance choice you’ll 
be able to apply for your accommodation (April 1st 
onwards).

3 The offer will show on 
UCAS track

2 The university will 
consider your offer

TOP TIP: Use UCAS Track to keep an eye on your 
application. At Aberystwyth we aim to make a decision 
within 4 weeks.

6 Results day 

UCAS Track will confirm your offer of a place. If you’re 
not clear what the offer is, contact the university 
directly. Make sure you’re not on holiday on results 
day. If you don’t get the grades you’ve hoped for, you 
may want to consider entering Clearing.

7 Start packing!

4 Decide where to go 

Once you’ve received all your offers, you’ll need to 
decide which university you want to go to, within 
a set time. This is when you’ll need to note which 
universities will be your firm and insurance choices.
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Aberdeen

EdinburghGlasgow

Liverpool

Manchester

Birmingham

LondonCardiff
Aberystwyth
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